← Back to issue list

Charmcraft cannot parse a dev version build for multipass

View original Github issue

Metadata

Project
charmcraft
Number
#1917
Type
issue
State
open
Author
jat-canonical
Labels
Type: Bug
Created
Updated
Closed
—

Current evaluation

Charmcraft pack fails on dev multipass versions like 1.15.0-dev.2929.pr661 due to invalid version parsing in craft-providers; fixed upstream and current charmcraft dependency includes the fix.

Suggested action: close resolved

Reason: Maintainer diagnosed the error as coming from craft-providers and filed canonical/craft-providers#661, which was fixed by canonical/craft-providers#662 (commit d7cfb80e). Charmcraft now requires craft-providers>=3.7.1 and uv.lock pins 3.7.1, so the upstream fix is included in current charmcraft dependencies.

Evaluated by: mr-cal-bot

Impact: 45 Quick Win: 34 Complexity: 15 Confidence: 85 Actionability: 90

Issue body

### Bug Description charmcraft throws invalid version for a dev build of multipass which follows sematic versioning spec. ### To Reproduce * Install a dev build of multipass * Run `charmcraft pack` ### Environment OSX 15.0 (Sequioa) ### charmcraft.yaml ```yaml N/A ``` ### Relevant log output ```shell charmcraft internal error: InvalidVersion("Invalid version: '1.15.0-dev.2929.pr661'") Full execution log: '/Users/X/Library/Logs/charmcraft/charmcraft-y-z.log' ```

Evaluation history

Date Model Scores Action Summary
~deepseek/deepseek-pro-latest
Impact: 45
Quick Win: 34
Complexity: 15
Confidence: 85
Actionability: 90
close resolved Charmcraft pack fails on dev multipass versions like 1.15.0-dev.2929.pr661 due to invalid version parsing in craft-providers; fixed upstream and current charmcraft dependency includes the fix.
~deepseek/deepseek-pro-latest
Impact: 45
Quick Win: 31
Complexity: 20
Confidence: 80
Actionability: 85
close resolved Charmcraft pack fails with InvalidVersion for Multipass dev builds like 1.15.0-dev.2929.pr661; root cause in craft-providers, fixed upstream and now included in charmcraft's dependency range.
stealth/space-bunny-alpha
Impact: 35
Quick Win: 30
Complexity: 10
Confidence: 98
Actionability: 95
close resolved Resolved: Multipass development versions could crash charmcraft; upstream parsing support was merged and Charmcraft now requires craft-providers>=3.7.1.
qwen/qwen3.6-35b-a3b
Impact: 30
Quick Win: 27
Complexity: 10
Confidence: 80
Actionability: 100
close resolved charmcraft fails to parse dev versions of multipass (e.g. 1.15.0-dev.2929.pr661) due to InvalidVersion error in craft-providers.
qwen/qwen3.8-27b
Impact: 50
Quick Win: 30
Staleness: 55
Complexity: 40
Confidence: 75
Support Request: 10
keep open Charmcraft pack fails with InvalidVersion on dev multipass builds (e.g. 1.15.0-dev.2929.pr661). Root cause traced to craft-providers version parsing; upstream fix landed in craft-providers. Issue is triaged and effectively resolved upstream.
qwen/qwen3.6-35b-a3b
Staleness: 85
Complexity: 15
Confidence: 90
Support Request: 0
close stale Charmcraft fails to parse a valid semver dev version from multipass, causing a build error. Maintainer identified the root cause as an upstream issue in craft-providers and linked a fix there.
qwen3.6-35b-a3b-mtp-q6
Staleness: 85
Complexity: 20
Confidence: 80
Support Request: 0
close stale Charmcraft fails to parse a dev version of multipass. Maintainer identified the root cause in craft-providers and linked an upstream issue. Issue remains open but inactive.
qwen3.6-35b-a3b-mtp-q6
Staleness: 85
Complexity: 15
Confidence: 80
Support Request: 0
close stale Charmcraft fails to parse a dev version of multipass, causing an InvalidVersion error during pack. A maintainer identified the root cause in the craft-providers dependency and opened an upstream issue, but the report has been inactive for over 7 months.

Update history

No update history recorded yet.

Related work

  • Caused By: canonical/craft-providers#661 (confidence 100%)

    Upstream bug report filed by charmcraft maintainer for invalid dev multipass version parsing.

  • Likely Fixed By: canonical/craft-providers#662 (confidence 95%)

    Merged upstream PR adding parsing support for dev multipass versions; charmcraft's current craft-providers>=3.7.1 dependency includes this fix.

Related issues

Issue Project State Summary Similarity
#2668 tests: add reproducer for dev multipass version causing InvalidVersion (#1917) charmcraft open Adds a failing unit test reproducing multipass dev-version InvalidVersion crash (#1917); root cause was fixed upstream in craft-providers#662, and charmcraft now requires craft-providers>=3.7.1.
72%
#796 Charmcraft pack on Apple Silicon fails charmcraft closed Pack failed on Apple Silicon because Multipass 1.9.1 could not find the 20.04 image; maintainer closed it as not a Charmcraft bug, fixed by updating to Multipass 1.9.2.
71%