chore(deps): update dependency yamllint to v1.35.1
Metadata
Current evaluation
yamllint 1.35.1 update was closed unmerged because Python 3.7 was unsupported; PR #868 later superseded it and merged the update in commit 60639226.
Resolution: closed superseded
Reason: A maintainer closed #705 because yamllint 1.35 did not support Python 3.7. The equivalent update was later merged through PR #868 in commit 60639226.
Evaluated by: mr-cal-bot
No scores available.
Issue body
[](https://renovatebot.com)
This PR contains the following updates:
| Package | Change | Age | Adoption | Passing | Confidence |
|---|---|---|---|---|---|
| [yamllint](https://togithub.com/adrienverge/yamllint) | `==1.32.0` -> `==1.35.1` | [](https://docs.renovatebot.com/merge-confidence/) | [](https://docs.renovatebot.com/merge-confidence/) | [](https://docs.renovatebot.com/merge-confidence/) | [](https://docs.renovatebot.com/merge-confidence/) |
---
### Release Notes
<details>
<summary>adrienverge/yamllint (yamllint)</summary>
### [`v1.35.1`](https://togithub.com/adrienverge/yamllint/blob/HEAD/CHANGELOG.rst#1351-2024-02-16)
[Compare Source](https://togithub.com/adrienverge/yamllint/compare/v1.35.0...v1.35.1)
- Restore ignoration of files passed as command-line arguments
- Revert API change from version 1.35.0
### [`v1.35.0`](https://togithub.com/adrienverge/yamllint/blob/HEAD/CHANGELOG.rst#1350-2024-02-15)
[Compare Source](https://togithub.com/adrienverge/yamllint/compare/v1.34.0...v1.35.0)
- Fix failure on broken symlinks that should be ignored
- API change: `linter.run(stream, config)` doesn't filter files anymore
- Docs: Restore official Read the Docs theme
### [`v1.34.0`](https://togithub.com/adrienverge/yamllint/blob/HEAD/CHANGELOG.rst#1340-2024-02-06)
[Compare Source](https://togithub.com/adrienverge/yamllint/compare/v1.33.0...v1.34.0)
- Config: validate `ignore-from-file` inside rules
- Rule `quoted-strings`: fix `only-when-needed` in flow maps and sequences
- Rule `key-duplicates`: add `forbid-duplicated-merge-keys` option
- Rule `quoted-strings`: add `check-keys` option
- Docs: add GitLab CI example
- Rule `truthy`: adapt forbidden values based on YAML version
### [`v1.33.0`](https://togithub.com/adrienverge/yamllint/blob/HEAD/CHANGELOG.rst#1330-2023-11-09)
[Compare Source](https://togithub.com/adrienverge/yamllint/compare/v1.32.0...v1.33.0)
- Add support for Python 3.12, drop support for Python 3.7
- Rule `document-end`: fix spurious "missing document end"
- Rule `empty-values`: add `forbid-in-block-sequences` option
</details>
---
### Configuration
📅 **Schedule**: Branch creation - "every weekend" in timezone Etc/UTC, Automerge - "every weekend" in timezone Etc/UTC.
🚦 **Automerge**: Disabled by config. Please merge this manually once you are satisfied.
♻ **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.
🔕 **Ignore**: Close this PR and you won't be reminded about this update again.
---
- [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box
---
This PR has been generated by [Mend Renovate](https://www.mend.io/free-developer-tools/renovate/). View repository job log [here](https://developer.mend.io/github/canonical/craft-parts).
<!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiIzNy4yNjkuMiIsInVwZGF0ZWRJblZlciI6IjM3LjI2OS4yIiwidGFyZ2V0QnJhbmNoIjoibWFpbiJ9-->
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed superseded | yamllint 1.35.1 update was closed unmerged because Python 3.7 was unsupported; PR #868 later superseded it and merged the update in commit 60639226. | |
| stealth/space-bunny-alpha | — | closed stale | yamllint 1.35.1 update was closed unmerged because v1.35 requires newer Python; it was later merged to main in #868 via commit 60639226. | |
| qwen/qwen3.6-35b-a3b | — | — | Closed without merging because yamllint v1.35.1 dropped Python 3.7 support. The update was rejected for compatibility reasons, and Renovate will ignore this version. | |
| qwen3.6-35b-a3b-mtp-q6 | — | — | Updating yamllint to v1.35.1 was closed without merging. The change was abandoned because yamllint 1.35 dropped Python 3.7 support, causing project incompatibility. |
Update history
No update history recorded yet.
Related work
-
Superseded By:
canonical/craft-parts#868
(confidence 100%)
Merged the same yamllint 1.35.1 update via commit 60639226.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #614 chore(deps): update dependency yamllint to v1.33.0 | craft-parts | closed | yamllint 1.33.0 PR #614 was closed unmerged and ignored; #868 later upgraded the pin from 1.32.0 to 1.35.1 in commit 60639226. | |
| #546 chore(deps): update dependency yamllint to v1.32.0 | craft-parts | merged | Merged PR #546 updated yamllint from 1.29.0 to 1.32.0 via commit 115b32c5. | |
| #1144 chore(deps): update dependency yamllint to v1.32.0 | charmcraft | merged | Merged PR #1144, updating yamllint from 1.29.0 to 1.32.0 in commit 2c06b8c5. | |
| #178 chore(deps): update dependency yamllint to v1.33.0 | starbase | merged | Renovate bumped yamllint 1.31.0 -> 1.33.0; PR #178 merged to main in commit 0cfc30a, a one-line change to the yamllint pin in .pre-commit-config.yaml. | |
| #51 chore(deps): update dependency yamllint to v1.31.0 | starbase | merged | Renovate dependency bump yamllint 1.29.0 -> 1.31.0 merged into main as commit 9de5c85; one-line .pre-commit-config.yaml change, approved and no failing CI. Later superseded by #178 (v1.33.0). | |
| #77 chore(deps): update dependency lint/yamllint to v1.32.0 | starbase | merged | Renovate PR #77 merged, bumping lint/yamllint from 1.31.0 to 1.32.0 via commit 4477363. | |
| #61 chore(deps): update dependency lint/yamllint to v1.31.0 | starbase | merged | Merged as dba8423, updating lint/yamllint from 1.29.0 to 1.31.0. | |
| #199 chore(deps): update development dependencies (non-major) | craft-application | merged | Merged in commit 9975801e, updating lint/yamllint 1.33.0→1.34.0 and types/pyright 1.1.349→1.1.350. | |
| #234 chore(deps): update development dependencies (non-major) | craft-cli | merged | Merged #234 in commit fc7221d, updating lint/yamllint 1.33.0→1.34.0 and types/pyright 1.1.349→1.1.350. | |
| #868 build(deps): update dependency yamllint to v1.35.1 (main) | craft-parts | merged | Merged PR #868 upgraded yamllint from 1.32.0 to 1.35.1 in main via commit 60639226. |