craft-providers incompatible with python 3.11
Metadata
Current evaluation
Reported Python 3.11 incompatibility in craft-providers, but maintainers (including the author) could not reproduce any errors; CI now tests 3.11/3.12 after merged PR #279. Closed as mistaken report.
Resolution: closed not a bug
Reason: lengau could not reproduce the failure under Python 3.11, and author mr-cal closed the issue stating "I was mistaken and am not having any issues with 3.11!". The only related change is merged PR canonical/craft-providers#279 ("ci: future-proofing Python tests"), which added 3.11/3.12 to the CI matrix rather than fixing any code defect.
Evaluated by: mr-cal-bot
No scores available.
Issue body
Craft-providers does not work with python 3.11.
While Python 3.11 compatibility is not an urgent requirement, it is a stepping stone towards ubuntu 24.04 + python 3.12 compatibility.
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed not a bug | Reported Python 3.11 incompatibility in craft-providers, but maintainers (including the author) could not reproduce any errors; CI now tests 3.11/3.12 after merged PR #279. Closed as mistaken report. | |
| qwen/qwen3.6-35b-a3b | — | closed not a bug | Author realized they were mistaken about Python 3.11 incompatibility; no actual errors were found, and CI was updated to test 3.11/3.12 in #279. |
Update history
| Date | Change |
|---|---|
| created |
Related work
-
Related To:
canonical/craft-providers#279
(confidence 92%)
PR opened by lengau in this issue's thread; merged CI matrix update adding Python 3.11/3.12 test runs, no source fix needed.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #611 build!: update minimum python version to 3.10 | craft-providers | merged | Merged in #611 via commit 7c49c19, raising craft-providers' minimum supported Python version to 3.10; related integration-test failures were fixed in #606. |