build(deps): update dependency myst-parser to v5 (main)
Metadata
Current evaluation
PR #359 was closed unmerged because myst-parser 5 requires Python 3.11 while craft-store still supports Python 3.10.
Resolution: closed stale
Reason: Maintainer @mr-cal stated on 2026-04-20 that v5 could not be adopted until Python 3.10 support was dropped. The PR was closed unmerged, and Renovate consequently ignored future 5.x releases.
Evaluated by: mr-cal-bot
No scores available.
Issue body
This PR contains the following updates:
| Package | Change | [Age](https://docs.renovatebot.com/merge-confidence/) | [Confidence](https://docs.renovatebot.com/merge-confidence/) |
|---|---|---|---|
| [myst-parser](https://redirect.github.com/executablebooks/MyST-Parser) | `==4.0.1` → `==5.0.0` |  |  |
---
### Release Notes
<details>
<summary>executablebooks/MyST-Parser (myst-parser)</summary>
### [`v5.0.0`](https://redirect.github.com/executablebooks/MyST-Parser/blob/HEAD/CHANGELOG.md#500---2026-01-15)
[Compare Source](https://redirect.github.com/executablebooks/MyST-Parser/compare/v4.0.1...v5.0.0)
This release significantly bumps the supported versions of core dependencies:
##### ‼️ Breaking Changes
This release updates the minimum supported versions:
- **Python**: `>=3.11` (dropped Python 3.10, tests up to 3.14)
- **Sphinx**: `>=8,<10` (dropped Sphinx 7, added Sphinx 9)
- **Docutils**: `>=0.20,<0.23` (dropped docutils 0.19, added docutils 0.22)
- **markdown-it-py**: `~=4.0` (upgraded from v3)
##### ⬆️ Dependency Upgrades
- ⬆️ Upgrade to markdown-it-py v4 by <gh-user:chrisjsewell> in <gh-pr:1060>
- ⬆️ Drop Python 3.10 and Sphinx 7 by <gh-user:chrisjsewell> in <gh-pr:1059>
- ⬆️ Drop docutils 0.19 by <gh-user:chrisjsewell> in <gh-pr:1061>
- ⬆️ Add support for Python 3.14 by <gh-user:chrisjsewell> in <gh-pr:1075>
- ⬆️ Support Sphinx v9 by <gh-user:chrisjsewell> in <gh-pr:1076>
- ⬆️ Allow docutils 0.22 by <gh-user:chrisjsewell> in <gh-pr:1084>
##### 👌 Improvements
- 👌 Improve generation of meta nodes by <gh-user:AA-Turner> in <gh-pr:1080>
##### 📚 Documentation
- 📚 Fix typo in tables.md by <gh-user:electricalgorithm> in <gh-pr:1034>
- 📚 Fix minor typo in `cross-referencing.md` by <gh-user:krassowski> in <gh-pr:1036>
##### 🔧 Internal / Maintenance
- 🔧 Update pre-commit by <gh-user:chrisjsewell> in <gh-pr:1058>
- 🔧 Add `AGENTS.md` by <gh-user:chrisjsewell> in <gh-pr:1083>
**Full Changelog**: [v4.0.1...v5.0.0](https://redirect.github.com/executablebooks/MyST-Parser/compare/v4.0.1...v5.0.0)
</details>
---
### Configuration
📅 **Schedule**: (in timezone Etc/UTC)
- Branch creation
- "every weekend"
- Automerge
- At any time (no schedule defined)
🚦 **Automerge**: Disabled by config. Please merge this manually once you are satisfied.
♻ **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.
🔕 **Ignore**: Close this PR and you won't be reminded about these updates again.
---
- [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box
---
This PR was generated by [Mend Renovate](https://mend.io/renovate/). View the [repository job log](https://developer.mend.io/github/canonical/craft-store).
<!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiI0My4xMjMuOCIsInVwZGF0ZWRJblZlciI6IjQzLjEyMy44IiwidGFyZ2V0QnJhbmNoIjoibWFpbiIsImxhYmVscyI6WyJQUjogRGVwZW5kZW5jaWVzIl19-->
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed stale | PR #359 was closed unmerged because myst-parser 5 requires Python 3.11 while craft-store still supports Python 3.10. | |
| stealth/space-bunny-alpha | — | closed stale | Renovate PR #359 was closed unmerged and 5.x ignored. The maintainer said myst-parser v5 could not be adopted until craft-store dropped Python 3.10. | |
| qwen/qwen3.6-35b-a3b | — | — | Rejected and closed without merging. The maintainer declined the myst-parser v5 update because it drops Python 3.10 support, which the project still requires. Renovate will ignore future 5.x updates. |
Update history
No update history recorded yet.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #183 build(deps): update dependency myst-parser to v5 (main) | craft-grammar | closed | Renovate PR #183 bumping myst-parser to ~=5.1 was closed unmerged by a maintainer; uv.lock resolution failed (needs sphinx 8), so the upgrade never landed. | |
| #553 build(deps): update dependency myst-parser to v5 (main) | starbase | closed | Renovate PR #553 was closed unmerged after uv could not lock myst-parser 5.1.0 for Python 3.15+, so starbase retained myst-parser 4.x. | |
| #282 build(deps): update dependency myst-parser to v5 (main) | imagecraft | closed | Renovate's myst-parser 5.1 update was closed unmerged after uv could not resolve uv.lock; Imagecraft kept myst-parser 4.x because v5 caused dependency conflicts. | |
| #481 build(deps): update dependency myst-parser to v5 (main) - autoclosed | starbase | closed | Renovate’s myst-parser 5.0 update was autoclosed unmerged after inactivity and a failing Trivy check; v4 remained pinned, while #537 later merged a broader docs-stack upgrade. | |
| #871 build(deps): update dependency myst-parser to v4 (main) | craft-parts | merged | Merged in canonical/craft-parts#871 via commit 8ab96720, upgrading myst-parser from 3.0.1 to 4.0.0 for documentation builds. | |
| #278 build(deps): update dependency sphinx to v8.2.3 (main) | craft-store | closed | Closed unmerged: Sphinx 8.2.3 requires Python 3.11+, conflicting with craft-store's Python 3.10 support; uv.lock could not resolve and CI checks failed. | |
| #209 build(deps): update bugfixes | craft-store | merged | Renovate PR merged as commit eeba1be, bumping mypy to 1.11.2, pyright 1.1.380, pytest 8.3.3 and tox-gh 1.3.3 in craft-store build config. | |
| #220 build(deps): update dependency myst-parser to v4 | craft-store | merged | Renovate PR #220 merged (commit fcca96b), bumping myst-parser 3.0.1 -> 4.0.0 (+2/-2 lines, 2 files). pyproject.toml docs-sphinx-stack group now requires myst-parser~=4.0. Approved by 2 reviewers, no failing CI. | |
| #1323 build(deps): update dependency mypy to ~=1.18.2 (main) | craft-parts | merged | Merged PR canonical/craft-parts#1323 via commit 3023f5b0, updating mypy from ~=1.14.1 to ~=1.18.2. | |
| #254 build(deps): update dependency setuptools to v75.8.0 | craft-store | merged | Renovate PR bumping craft-store's setuptools build requirement from 75.6.0 to 75.8.0 in pyproject.toml was approved and merged into main as commit 13c676e (one-line change). |