The 'requests' dependency should have a minimum version
Metadata
Current evaluation
Set requests>=2.27 as the minimum in setup.cfg via PR #94 (commit 1a0a2e7), preventing failures with older requests versions lacking JSONDecodeError.
Resolution: closed resolved
Reason: Resolved by PR #94, merged as commit 1a0a2e7, which changed setup.cfg to require requests version 2.27 or newer.
Evaluated by: mr-cal-bot
No scores available.
Issue body
Focal brings request 2.25 which does not have `JSONDecodeError`.
```
File "/usr/local/lib/python3.10/dist-packages/craft_store/__init__.py", line 22, in <module>
from . import endpoints, errors, models
File "/usr/local/lib/python3.10/dist-packages/craft_store/errors.py", line 25, in <module>
from requests.exceptions import JSONDecodeError
```
We should specify the minimum version needed for requests in setup.cfg
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Set requests>=2.27 as the minimum in setup.cfg via PR #94 (commit 1a0a2e7), preventing failures with older requests versions lacking JSONDecodeError. | |
| stealth/space-bunny-alpha | — | closed resolved | Fixed by setting requests>=2.27 in setup.cfg via PR #94 (commit 1a0a2e7), preventing failures on versions without JSONDecodeError. | |
| stealth/space-bunny-alpha | — | closed stale | Requested a minimum requests version because 2.25 lacks JSONDecodeError; the issue is closed, but no resolving PR or commit is identified in the available metadata. | |
| qwen/qwen3.6-35b-a3b | — | — | Closed without resolution. The requested minimum version constraint for the requests dependency was not added to setup.cfg. | |
| qwen/qwen3.6-35b-a3b | — | — | Closed and resolved by updating the minimum requests version in setup.cfg to ensure JSONDecodeError compatibility and prevent import errors. | |
| qwen/qwen3.6-35b-a3b | — | — | Closed without comments, indicating the minimum requests version constraint was added to setup.cfg or the report was abandoned. |
Update history
No update history recorded yet.
Related work
-
Likely Fixed By:
canonical/craft-store#94
(confidence 100%)
Commit 1a0a2e7 from PR #94 set requests 2.27 as the minimum required version.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #94 #64 set 2.27 version number as minimum for requests package in setup.cfg | craft-store | merged | Merged PR #94 (commit 1a0a2e7) setting requests>=2.27 as the minimum version in setup.cfg, fixing #64 where requests 2.25 lacked JSONDecodeError. |