charmcraft build fails with LXD version
Metadata
Current evaluation
User support request: charmcraft build/pack failed with "LXD '3.0.3' does not meet the minimum required version '4.0'". facundobatista confirmed LXD 4.0+ is required by design and suggested --destructive-mode; no code change.
Resolution: closed not a bug
Reason: Closed as a support/documented-behaviour question, not a defect: the maintainer replied on 2022-02-25 that charmcraft's default pack path provisions an LXD instance and therefore needs LXD 4.0+, and that the user can instead pass --destructive-mode to build on the host. The message originates from craft-providers' lxd/installer.py _ensure_lxd_ready version check, which is intentional.
Evaluated by: mr-cal-bot
Issue body
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed not a bug | User support request: charmcraft build/pack failed with "LXD '3.0.3' does not meet the minimum required version '4.0'". facundobatista confirmed LXD 4.0+ is required by design and suggested --destructive-mode; no code change. | |
| stealth/space-bunny-alpha | — | closed not a bug | No code change needed: a maintainer confirmed LXD 4.0+ is required for default builds and suggested --destructive-mode to build on the host instead. | |
| stealth/space-bunny-alpha | — | closed not a bug | Closed as expected behavior: default packing requires LXD 4.0+; a maintainer offered --destructive-mode as an alternative on 2022-02-25. | |
| qwen3.6-35b-a3b-mtp-q6 | — | — | Closed as working as intended. Maintainer clarified LXD 4.0+ is required for default builds and provided the --destructive-mode flag as an alternative to bypass the dependency. | |
| qwen/qwen3.6-35b-a3b | — | — | Closed after maintainer confirmed LXD 4.0+ is required for default builds. Provided the --destructive-mode flag as an alternative to build charms without LXD. No code changes were made. | |
| qwen3.6-35b-a3b-mtp-q6 | — | — | Closed as answered. Charmcraft requires LXD 4.0+ for default containerized builds. A maintainer confirmed the requirement and provided the --destructive-mode flag as a workaround to build locally without LXD. |
Update history
No update history recorded yet.
Related work
-
Related To:
canonical/charmcraft#506
(confidence 62%)
Another charmcraft build failure traced to the same LXD 4.0+ requirement (missing project support), also closed without a code fix.
-
Related To:
canonical/craft-providers#92
(confidence 45%)
Later LXD-version-related charmcraft pack failure, but a different root cause (LXD snap device-name validation) resolved in craft-providers 1.23.1, not applicable to this 2022 support question.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #1640 Incompatibility with latest LXD LTS | charmcraft | closed | Fixed in Charmcraft 2.6.0 by merged PR #1641 (commit 2248543f), shipping the craft-providers 1.23.1 fix for LXD versions with the LTS suffix; released to stable. | |
| #685 charmcraft pack errors with LXDError - Name can only contain alphanumeric and hyphen characters | charmcraft | closed | Packing failures came from an upstream LXD 4.23 device-name validation regression, fixed in revision 22525 or later; no Charmcraft code change was needed. | |
| #92 Suddenly getting charmcraft internal error with charmcraft pack | craft-providers | closed | Resolved upstream in LXD 4.23 revision 22525+, which corrected overly strict device-name validation; `snap revert lxd` was a temporary workaround. | |
| #2833 charmcraft no longer available for `armhf` | charmcraft | closed | Closed as not planned: #2412 deliberately dropped armhf from the charmcraft snap with Charmcraft 4. Charmcraft 3.x track still works; LXD will keep its last armhf revision in the store and stop publishing new ones. |