← Back to issue list

pip install charmcraft installs v1.0

View original Github issue

Metadata

Project
charmcraft
Number
#816
Type
issue
State
closed
Author
tbaumann
Labels
—
Created
Updated
Closed

Current evaluation

Closed as expected behaviour: on Ubuntu 18.04 with Python 3.6, pip backtracked to Charmcraft 1.0.0 because newer deps (e.g. humanize) require Python >=3.7. Maintainer also fixed a release glitch so 2.0.0 was on PyPI; reporter confirmed Focal works.

Resolution: closed not a bug

Reason: facundobatista closed the issue on 2022-08-05 explaining that recent dependencies need Python newer than 3.6.9, so older platforms get older charmcraft, and the reporter confirmed it works on focal. An incidental release-process glitch (PyPI stuck at 1.7.1) was fixed by publishing 2.0.0, but no code fix was needed.

Evaluated by: mr-cal-bot

No scores available.

Issue body

I need to run charmcraft in docker, therefore snap isn't really an option. (even lxd will be problematic but at least I have `--destructive-mode`) But I just noticed that `pip install charmcraft` installs a totally prehistoric version. Is the pip version truly deprecated? What is the plan here? Thanks Tilman

Evaluation history

Date Model Scores Action Summary
stealth/space-bunny-alpha — closed not a bug Closed as expected behaviour: on Ubuntu 18.04 with Python 3.6, pip backtracked to Charmcraft 1.0.0 because newer deps (e.g. humanize) require Python >=3.7. Maintainer also fixed a release glitch so 2.0.0 was on PyPI; reporter confirmed Focal works.
stealth/space-bunny-alpha — closed not a bug Closed as expected behavior: Python 3.6 on Ubuntu 18.04 caused pip to backtrack to Charmcraft 1.0; upgrading to Focal/Python 3.7+ installed the current release.
qwen3.6-35b-a3b-mtp-q6 — — Closed as expected behavior. Python 3.6 on Ubuntu 18.04 forced pip to install an older compatible version due to dependency constraints. Resolved after the user upgraded to Ubuntu Focal with Python 3.7+.
qwen/qwen3.6-35b-a3b — — Closed as expected behavior. Python 3.6.9 on Ubuntu 18.04 is incompatible with newer charmcraft dependencies requiring Python >= 3.7. User confirmed successful installation on Ubuntu 20.04.
qwen3.6-35b-a3b-mtp-q6 — — Closed as expected behavior. Pip reverted to v1.0 due to Python 3.6.9 incompatibility with newer dependencies on Ubuntu 18.04. Upgrading to Ubuntu 20.04 resolved the issue, enabling correct v2.0.0 installation.

Update history

No update history recorded yet.

Related work

  • Related To: canonical/charmcraft#615 (confidence 62%)

    Prior issue about pip install charmcraft failures, resolved by PyPI install instructions in the README, which the maintainer cited here.

Related issues

Issue Project State Summary Similarity
#615 Can't pip install charmcraft on latest Ubuntu charmcraft closed Closed through documentation: PR #691 (commit 8204c111) added PyPI installation instructions after the reporter confirmed pip installation itself succeeded.
75%
#1716 feat: upgrade minimum pip version charmcraft merged Merged in canonical/charmcraft#1716 (def89c50), raising Charmcraft's minimum required pip version; the update was backported to 2.x by #1723 (5e119c36).
70%