← Back to issue list

feat: upgrade minimum pip version

View original Github issue

Metadata

Project
charmcraft
Number
#1716
Type
pull request
State
merged
Author
lengau
Labels
—
Created
Updated
Closed

Current evaluation

Merged in canonical/charmcraft#1716 (def89c50), raising Charmcraft's minimum required pip version; the update was backported to 2.x by #1723 (5e119c36).

Resolution: closed resolved

Reason: PR #1716 was approved by two reviewers and merged as commit def89c50. A follow-up backport, PR #1723, also merged as 5e119c36.

Evaluated by: mr-cal-bot

No scores available.

Issue body

No description provided.

Evaluation history

Date Model Scores Action Summary
stealth/space-bunny-alpha — closed resolved Merged in canonical/charmcraft#1716 (def89c50), raising Charmcraft's minimum required pip version; the update was backported to 2.x by #1723 (5e119c36).
stealth/space-bunny-alpha — closed resolved Merged after approval by two reviewers, raising the minimum required pip version.
qwen/qwen3.6-35b-a3b — — Merged the feature to upgrade the minimum pip version. Changes modified two files with 45 additions and 8 deletions. Approved by two reviewers and successfully integrated.
qwen3.6-35b-a3b-mtp-q6 — — Merged to upgrade the minimum required pip version. The maintainer integrated the change, updating build dependencies to enforce a newer pip release.

Update history

No update history recorded yet.

Related work

Related issues

Issue Project State Summary Similarity
#1437 fix(charm_builder): bump minimum pip version to 23 charmcraft merged Merged #1437 in commit fe263387, raising charm_builder's minimum pip to 23 so strict dependencies use the prebuilt wheel cache; released in Charmcraft 2.5.4.
80%
#1723 fix: backport pip version update to 2.x charmcraft merged Backported the pip version update to the 2.x branch and merged it in canonical/charmcraft#1723 via commit 5e119c36.
78%
#1456 Strict dependencies prevents charm from building charmcraft closed Fixed in PR #1716 (commit def89c50): Charmcraft raised its minimum pip version so strict-dependency builds upgrade old virtual environments first.
74%
#1892 fix(charm_builder): force-install pip charmcraft merged Merged PR #1892 (358657b6) added a Charmcraft 3.x hotfix to force-upgrade an insufficient pip in existing venvs, fixing #1456.
74%
#1374 pip wheel cache ignored charmcraft closed Pip 23 restored use of Charmcraft's shared wheel cache. The fix merged in canonical/charmcraft#1437 (fe263387), was backported by #1723, and shipped in Charmcraft 2.5.4.
72%
#816 pip install charmcraft installs v1.0 charmcraft closed Closed as expected behaviour: on Ubuntu 18.04 with Python 3.6, pip backtracked to Charmcraft 1.0.0 because newer deps (e.g. humanize) require Python >=3.7. Maintainer also fixed a release glitch so 2.0.0 was on PyPI; reporter confirmed Focal works.
70%
#1352 chore: bump minimum Python version to 3.10 charmcraft merged Merged PR #1352 in commit b04b03bf, raising Charmcraft's minimum Python to 3.10, dropping Python 3.8, and updating tooling and CI tests for core22.
70%