build(deps): update dependency sphinx-autobuild to v2025
Metadata
Current evaluation
Closed unmerged: sphinx-autobuild 2025.8.25 requires Python 3.11, so uv.lock could not resolve the Python 3.10 environment; the same update was later retried in #46.
Resolution: closed superseded
Reason: Renovate reported that PR #32's artifact update failed because 2025.8.25 requires Python >=3.11 while the project supports Python 3.10; the dependency remains ~=2024.2. The later identical attempt in #46 was also closed unmerged.
Evaluated by: mr-cal-bot
No scores available.
Issue body
This PR contains the following updates:
| Package | Change | Age | Confidence |
|---|---|---|---|
| [sphinx-autobuild](https://redirect.github.com/sphinx-doc/sphinx-autobuild#readme) ([changelog](https://redirect.github.com/sphinx-doc/sphinx-autobuild/blob/main/NEWS.rst)) | `~=2024.2` -> `~=2025.8` | [](https://docs.renovatebot.com/merge-confidence/) | [](https://docs.renovatebot.com/merge-confidence/) |
---
### Release Notes
<details>
<summary>sphinx-doc/sphinx-autobuild (sphinx-autobuild)</summary>
### [`v2025.8.25`](https://redirect.github.com/sphinx-doc/sphinx-autobuild/compare/2024.10.03...2025.08.25)
[Compare Source](https://redirect.github.com/sphinx-doc/sphinx-autobuild/compare/2024.10.03...2025.08.25)
</details>
---
### Configuration
π
**Schedule**: Branch creation - "every weekend" in timezone Etc/UTC, Automerge - At any time (no schedule defined).
π¦ **Automerge**: Disabled by config. Please merge this manually once you are satisfied.
β» **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.
π **Ignore**: Close this PR and you won't be reminded about this update again.
---
- [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box
---
This PR was generated by [Mend Renovate](https://mend.io/renovate/). View the [repository job log](https://developer.mend.io/github/canonical/craft-artifacts).
<!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiI0MS45MS4xIiwidXBkYXRlZEluVmVyIjoiNDEuOTEuMSIsInRhcmdldEJyYW5jaCI6Im1haW4iLCJsYWJlbHMiOlsiUFI6IERlcGVuZGVuY2llcyJdfQ==-->
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | β | closed superseded | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python 3.11, so uv.lock could not resolve the Python 3.10 environment; the same update was later retried in #46. | |
| stealth/space-bunny-alpha | β | closed not a bug | Renovate PR #32 was closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, but craft-artifacts supports Python >=3.10, so uv could not update uv.lock. | |
| stealth/space-bunny-alpha | β | closed stale | PR #32 closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, so uv lock failed for the projectβs Python 3.10 environment; Renovate ignored future 2025.x updates. | |
| stealth/space-bunny-alpha | β | closed stale | Renovate PR #32 was closed unmerged after uv.lock could not resolve sphinx-autobuild 2025.8.25 on Python 3.10; the release requires Python 3.11+. Future 2025.x updates were ignored. | |
| qwen/qwen3.6-35b-a3b | β | β | Abandoned due to Python version incompatibility. sphinx-autobuild v2025.8.25 requires Python 3.11+, conflicting with the project's Python 3.10 support. Renovate will ignore future 2025.x updates. | |
| qwen3.6-35b-a3b-mtp-q6 | β | β | Closed without merging due to a Python version conflict. The updated sphinx-autobuild v2025 requires Python 3.11+, but the project uses 3.10, causing a dependency resolution failure. Renovate will ignore future 2025.x updates. |
Update history
No update history recorded yet.
Related work
-
Superseded By:
canonical/craft-artifacts#46
(confidence 92%)
Later Renovate PR repeated the same sphinx-autobuild 2025 update and encountered the same Python 3.10 incompatibility.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #436 build(deps): update dependency sphinx-autobuild to v2025 | starbase | closed | Closed unmerged: sphinx-autobuild 2025.8.25 required Python >=3.11, so uv could not resolve the Python 3.10 lock split; Renovate ignored future 2025.x updates. | |
| #1030 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-providers | closed | Dependency update to sphinx-autobuild v2025.8.25 closed due to Python 3.10 incompatibility. The new version requires Python >=3.11, causing uv.lock resolution to fail. | |
| #16 build(deps): update dependency sphinx-autobuild to v2025 | debcraft | closed | Closed unmerged after uv lock failed because sphinx-autobuild 2025.8.25 requires Python 3.11 while debcraft supports 3.10. A later identical update, PR #30, was also closed unmerged. | |
| #165 build(deps): update dependency sphinx-autobuild to v2025 | craft-platforms | closed | Closed unmerged after Renovate could not update uv.lock for sphinx-autobuild 2025.8.25 on Python 3.10; no fixing commit landed. | |
| #895 build(deps): update dependency sphinx-autobuild to v2025 (hotfix/5.9) | craft-application | closed | Closed unmerged after uv could not resolve sphinx-autobuild 2025.8.25 for Python 3.10; Renovate then ignored future 2025.x updates. | |
| #188 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-platforms | closed | Renovate's sphinx-autobuild 2025 update was closed unmerged after uv could not resolve uv.lock for Python 3.10; no update landed. | |
| #883 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-application | closed | Renovate PR #883 was closed unmerged after uv could not resolve sphinx-autobuild 2025.8.25 for Python 3.10; 2025.8.25 later entered uv.lock via #1085 (2a6a7320). | |
| #149 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-grammar | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, but craft-grammar supports Python 3.10, so uv could not resolve uv.lock. | |
| #456 build(deps): update dependency sphinx-autobuild to v2025 (main) | starbase | closed | Closed unmerged after uv could not resolve sphinx-autobuild 2025.8.25 on supported Python 3.10; Renovate is now ignoring future 2025.x updates. | |
| #815 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-providers | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, so the lockfile update failed in craft-providers' supported Python 3.10 environment. |