build(deps): update dependency sphinx-autobuild to v2025 (main)
Metadata
Current evaluation
Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, so the lockfile update failed in craft-providers' supported Python 3.10 environment.
Resolution: closed not a bug
Reason: Renovate reported no dependency solution for Python 3.10 because sphinx-autobuild 2025.8.25 requires Python >=3.11. The PR was closed without merging, and pyproject.toml remains pinned to sphinx-autobuild ~=2024.10.
Evaluated by: mr-cal-bot
No scores available.
Issue body
This PR contains the following updates:
| Package | Change | Age | Confidence |
|---|---|---|---|
| [sphinx-autobuild](https://redirect.github.com/sphinx-doc/sphinx-autobuild#readme) ([changelog](https://redirect.github.com/sphinx-doc/sphinx-autobuild/blob/main/NEWS.rst)) | `~=2024.10` -> `~=2025.8` | [](https://docs.renovatebot.com/merge-confidence/) | [](https://docs.renovatebot.com/merge-confidence/) |
---
### Release Notes
<details>
<summary>sphinx-doc/sphinx-autobuild (sphinx-autobuild)</summary>
### [`v2025.8.25`](https://redirect.github.com/sphinx-doc/sphinx-autobuild/compare/2024.10.03...2025.08.25)
[Compare Source](https://redirect.github.com/sphinx-doc/sphinx-autobuild/compare/2024.10.03...2025.08.25)
</details>
---
### Configuration
📅 **Schedule**: Branch creation - "every weekend" in timezone Etc/UTC, Automerge - At any time (no schedule defined).
🚦 **Automerge**: Disabled by config. Please merge this manually once you are satisfied.
♻ **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.
🔕 **Ignore**: Close this PR and you won't be reminded about this update again.
---
- [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box
---
This PR was generated by [Mend Renovate](https://mend.io/renovate/). View the [repository job log](https://developer.mend.io/github/canonical/craft-providers).
<!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiI0MS45MS4xIiwidXBkYXRlZEluVmVyIjoiNDEuOTEuMSIsInRhcmdldEJyYW5jaCI6Im1haW4iLCJsYWJlbHMiOlsiUFI6IERlcGVuZGVuY2llcyJdfQ==-->
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed not a bug | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, so the lockfile update failed in craft-providers' supported Python 3.10 environment. | |
| qwen/qwen3.6-35b-a3b | — | closed not a bug | Dependency update to sphinx-autobuild v2025.8.25 was closed because it requires Python >= 3.11, breaking the project's Python 3.10 environment. |
Update history
| Date | Change |
|---|---|
| created |
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #16 build(deps): update dependency sphinx-autobuild to v2025 | debcraft | closed | Closed unmerged after uv lock failed because sphinx-autobuild 2025.8.25 requires Python 3.11 while debcraft supports 3.10. A later identical update, PR #30, was also closed unmerged. | |
| #32 build(deps): update dependency sphinx-autobuild to v2025 | craft-artifacts | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python 3.11, so uv.lock could not resolve the Python 3.10 environment; the same update was later retried in #46. | |
| #1030 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-providers | closed | Dependency update to sphinx-autobuild v2025.8.25 closed due to Python 3.10 incompatibility. The new version requires Python >=3.11, causing uv.lock resolution to fail. | |
| #436 build(deps): update dependency sphinx-autobuild to v2025 | starbase | closed | Closed unmerged: sphinx-autobuild 2025.8.25 required Python >=3.11, so uv could not resolve the Python 3.10 lock split; Renovate ignored future 2025.x updates. | |
| #149 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-grammar | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, but craft-grammar supports Python 3.10, so uv could not resolve uv.lock. | |
| #46 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-artifacts | closed | Renovate PR #46 (sphinx-autobuild 2024.2 -> 2025.8) was closed unmerged: the lockfile update failed because 2025.8.25 needs Python >=3.11 while the project still supports 3.10. pyproject.toml still pins ~=2024.2. | |
| #206 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-archives | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11 but craft-archives requires-python is >=3.10, so uv lock failed and Renovate ignored future 2025.x releases. pyproject.toml still has sphinx-autobuild>=2024.10.3. | |
| #120 build(deps): update dependency sphinx-autobuild to v2025 | craft-grammar | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python 3.11+, while craft-grammar supports Python 3.10, so Renovate could not update uv.lock. | |
| #456 build(deps): update dependency sphinx-autobuild to v2025 (main) | starbase | closed | Closed unmerged after uv could not resolve sphinx-autobuild 2025.8.25 on supported Python 3.10; Renovate is now ignoring future 2025.x updates. | |
| #895 build(deps): update dependency sphinx-autobuild to v2025 (hotfix/5.9) | craft-application | closed | Closed unmerged after uv could not resolve sphinx-autobuild 2025.8.25 for Python 3.10; Renovate then ignored future 2025.x updates. |