build!: drop support for Python 3.8
Metadata
Current evaluation
Merged PR #20 in commit 50ee613, dropping Python 3.8 support across five files after approval by two reviewers.
Resolution: closed resolved
Reason: The breaking change completed successfully and was merged as commit 50ee613. PR #20 received two approvals with no unresolved review comments.
Evaluated by: mr-cal-bot
No scores available.
Issue body
- [ ] Have you signed the [CLA](http://www.ubuntu.com/legal/contributors/)?
-----
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #20 in commit 50ee613, dropping Python 3.8 support across five files after approval by two reviewers. | |
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #20, dropping Python 3.8 support across five files with two approvals; implemented in commit 50ee613. | |
| qwen/qwen3.6-35b-a3b | — | — | Merged following approval by two reviewers. The maintainer modified five files to remove Python 3.8 from build toolchains and compatibility checks, officially dropping legacy support. |
Update history
No update history recorded yet.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #318 drop support for old python versions | craft-cli | closed | Minimum Python raised to 3.10 in merged PR #320 (commit c35189b, 'chore!: bump minimum python version to 3.10'), dropping 3.8/3.9; pyproject.toml now has requires-python >=3.10. |