← Back to issue list

drop support for old python versions

View original Github issue

Metadata

Project
craft-cli
Number
#318
Type
issue
State
closed
Author
bepri
Labels
—
Created
Updated
Closed

Current evaluation

Minimum Python raised to 3.10 in merged PR #320 (commit c35189b, 'chore!: bump minimum python version to 3.10'), dropping 3.8/3.9; pyproject.toml now has requires-python >=3.10.

Resolution: closed resolved

Reason: Requested shift of the support window to 3.10-3.12 was implemented in merged PR #320 via commit c35189b, which set requires-python = ">=3.10" and updated classifiers; the issue was closed as done by the maintainer.

Evaluated by: mr-cal-bot

No scores available.

Issue body

### What needs to get done Currently, craft-cli supports the now-EOL Python 3.8 and the nearly-EOL Python 3.9. I think the support window should be shifted forward to be 3.10-3.12 if possible. ### Why it needs to get done EOL software is scary

Evaluation history

Date Model Scores Action Summary
stealth/space-bunny-alpha — closed resolved Minimum Python raised to 3.10 in merged PR #320 (commit c35189b, 'chore!: bump minimum python version to 3.10'), dropping 3.8/3.9; pyproject.toml now has requires-python >=3.10.
stealth/space-bunny-alpha — closed resolved Raised the minimum Python version to 3.10 in merged PR #320 (commit c35189b), completing the requested shift from Python 3.8–3.9.
qwen/qwen3.6-35b-a3b — — Closed without implementation. The request to drop Python 3.8 and 3.9 support in favor of 3.10-3.12 was not addressed. No pull request was opened or merged, indicating the change was deferred or abandoned.
qwen/qwen3.8-27b
Impact: 35
Quick Win: 24
Staleness: 75
Complexity: 30
Confidence: 85
Support Request: 0
close stale Request to drop EOL Python 3.8/3.9 and shift craft-cli's support window to 3.10-3.12. The minimum Python version was since bumped to 3.10 (PR #320) and CI now tests 3.10-3.14, so the core ask is implemented; the issue is stale and can be closed.
qwen/qwen3.6-35b-a3b
Staleness: 90
Complexity: 20
Confidence: 85
Support Request: 5
needs triage Maintainer proposes dropping EOL Python 3.8 and 3.9 support, shifting compatibility to 3.10-3.12. Issue lacks labels, has no assignee, and has been inactive for over 16 months.
qwen3.6-35b-a3b-mtp-q6
Staleness: 85
Complexity: 35
Confidence: 80
Support Request: 10
needs triage Request to drop support for EOL Python 3.8 and 3.9, updating the supported range to 3.10-3.12. Open for over a year with no maintainer discussion or labels.

Update history

Date Change
closed

Related work

  • Likely Fixed By: canonical/craft-cli#320 (confidence 95%)

    Merged PR #320 (commit c35189b 'chore!: bump minimum python version to 3.10') changed pyproject.toml to requires-python >=3.10, matching the issue's request.

  • Related To: canonical/craft-cli#377 (confidence 45%)

    Later commit 6bfa969 'chore: prepare for Python 3.14' further widened the support window beyond 3.10-3.12.

Related issues

Issue Project State Summary Similarity
#5522 Drop minimum Python version to 3.10 snapcraft closed Minimum Python in pyproject.toml lowered from 3.12 to 3.10 by merged PR #5547 (commit f0532a15d), unblocking the core22-8 rock; maintainer mr-cal closed the issue citing that PR.
81%
#116 Drop Python < 3.10 craft-archives closed Python 3.9 and older support was removed by merged PR #117, raising the minimum supported version to Python 3.10 (commit ccfdcbf).
77%
#381 chore: drop ubuntu 20.04 and python 3.8 rockcraft merged Merged PR #381 (commit 87c0f1f9) by tigarmo: dropped Ubuntu 20.04 and Python 3.8 support, bumping requires-python to >=3.10 in pyproject.toml and adding Python 3.12 to CI test matrix.
74%
#729 Bump minimum Python version to 3.10 craft-parts closed Minimum Python support was raised to 3.10 in commit 54b8fab4; merged PR #742 completed the broader compatibility cleanup.
73%
#742 chore: move python version compatibility to 3.10 craft-parts merged Merged PR canonical/craft-parts#742 (a80f9c26): raises craft-parts Python floor to 3.10 across packaging, code and typing cleanups (Optional/Union removed); pyproject.toml now declares requires-python >=3.10.
72%
#20 build!: drop support for Python 3.8 craft-grammar merged Merged PR #20 in commit 50ee613, dropping Python 3.8 support across five files after approval by two reviewers.
71%