← Back to issue list

multipass: is_supported_version() interface and require >=1.7

View original Github issue

Metadata

Project
craft-providers
Number
#42
Type
pull request
State
merged
Author
cjp256
Labels
—
Created
Updated
Closed

Current evaluation

Merged in craft-providers#42 via ce6356d; commit 1166096 added Multipass.is_supported_version() and raised the minimum supported version to 1.7.

Resolution: closed resolved

Reason: The approved PR was merged through commit ce6356d. Commit 1166096 implements the version-support interface, enforces Multipass >=1.7, and removes the obsolete skipped test.

Evaluated by: mr-cal-bot

No scores available.

Issue body

In preparation for multipass release, add interface for supported version and remove skipped test for multipass issue in now-unsupported versions.

Evaluation history

Date Model Scores Action Summary
stealth/space-bunny-alpha — closed resolved Merged in craft-providers#42 via ce6356d; commit 1166096 added Multipass.is_supported_version() and raised the minimum supported version to 1.7.
qwen/qwen3.6-35b-a3b — closed resolved Added `is_supported_version()` interface for multipass and updated requirement to >=1.7, removing skipped tests for unsupported versions.

Update history

Date Change
created

Related issues

Issue Project State Summary Similarity
#1796303 Check version of multipass snapcraft (launchpad) closed Added a Multipass minimum-version check via canonical/craft-providers#42, requiring Multipass 1.7+; merged as ce6356d.
83%
#75 multipass: introduce ensure_multipass_is_ready() (CRAFT-438) craft-providers merged Merged PR #75 added ensure_multipass_is_ready() to verify Multipass installation and version support; merge commit 1f1ddce.
74%
#491 providers: introduce multipass support (CRAFT-409) charmcraft merged Multipass support was merged in canonical/charmcraft#491 via merge commit 1b855093, with implementation commit 84132dc1 adding provider selection and tests.
74%
#628 Check Multipass version for 24.04 VMs craft-providers closed Implemented a Multipass >=1.14.1 requirement for Noble/24.04 launches in commit a977369 and released it in craft-providers 1.24.2 and 2.0.1.
73%
#9 multipass: introduce Multipass and MultipassError craft-providers merged PR #9 by cjp256 merged into craft-providers (commit e418497), adding a Multipass class wrapping the multipass CLI plus MultipassError, unit/integration tests (test_todo dropped), and pytest-subprocess in requirements-dev.
73%
#16 multipass: add version() and wait_until_ready() to Multipass craft-providers merged Merged PR #16 added Multipass version() and wait_until_ready(), with the readiness helper returning the detected version.
71%