Check Multipass version for 24.04 VMs
Metadata
Current evaluation
Implemented a Multipass >=1.14.1 requirement for Noble/24.04 launches in commit a977369 and released it in craft-providers 1.24.2 and 2.0.1.
Resolution: closed resolved
Reason: Commit a977369 added the required Noble version check. The 1.24.2 and 2.0.1 changelogs confirm that 24.04 launches now require Multipass 1.14.1 or newer.
Evaluated by: mr-cal-bot
No scores available.
Issue body
### What needs to get done
Check if the multipass version is >= 1.14.1 when launching a 24.04 buildd image (`multipass launch snapcraft:core24`).
Recommend the user to install 1.14.1 or newer from the candidate, beta, or edge channels.
~~Alternatively, craft-providers could call `multipass launch https://cloud-images.ubuntu.com/buildd/daily/noble/current/noble-server-cloudimg-<arch>-disk1.img`~~
Work includes a release and PRs for downstream apps.
### Why it needs to get done
Multipass 1.15 may not be released for another month.
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Implemented a Multipass >=1.14.1 requirement for Noble/24.04 launches in commit a977369 and released it in craft-providers 1.24.2 and 2.0.1. | |
| qwen/qwen3.6-35b-a3b | — | closed stale | Issue to check Multipass version >= 1.14.1 for 24.04 VMs was closed without implementation or PR mentioned |
Update history
| Date | Change |
|---|---|
| created |
Related work
-
Likely Fixed By:
canonical/craft-providers#694
(confidence 88%)
PR #694 consolidated the Multipass 1.14.1 minimum-version requirement.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #640 fix: require multipass>=1.14.1 for Ubuntu 24.04 (Noble) | craft-providers | merged | Merged PR #640 (commit a977369) requiring Multipass >=1.14.1 for Ubuntu 24.04 Noble VMs, fixing #628 after the snapcraft:devel alias moved to 24.10 images. | |
| #1796303 Check version of multipass | snapcraft (launchpad) | closed | Added a Multipass minimum-version check via canonical/craft-providers#42, requiring Multipass 1.7+; merged as ce6356d. | |
| #75 multipass: introduce ensure_multipass_is_ready() (CRAFT-438) | craft-providers | merged | Merged PR #75 added ensure_multipass_is_ready() to verify Multipass installation and version support; merge commit 1f1ddce. | |
| #602 fix(multipass): use Ubuntu 24.04 image | craft-providers | merged | Merged PR #602 updated Multipass Noble to the Ubuntu 24.04 buildd daily image, fixing #511. Resolved by commit a369826. | |
| #42 multipass: is_supported_version() interface and require >=1.7 | craft-providers | merged | Merged in craft-providers#42 via ce6356d; commit 1166096 added Multipass.is_supported_version() and raised the minimum supported version to 1.7. | |
| #9 multipass: introduce Multipass and MultipassError | craft-providers | merged | PR #9 by cjp256 merged into craft-providers (commit e418497), adding a Multipass class wrapping the multipass CLI plus MultipassError, unit/integration tests (test_todo dropped), and pytest-subprocess in requirements-dev. | |
| #5006 build(deps): bump craft-providers to 1.24.2 | snapcraft | merged | Merged via #5006 as commit 96140ad2a, updating craft-providers to 1.24.2 and requiring Multipass >=1.14.1 for Ubuntu 24.04 core24 builds. | |
| #491 providers: introduce multipass support (CRAFT-409) | charmcraft | merged | Multipass support was merged in canonical/charmcraft#491 via merge commit 1b855093, with implementation commit 84132dc1 adding provider selection and tests. | |
| #638 Bump minimum version of Multipass to 1.14.1 | craft-providers | closed | Fixed by merged PR #694 (commit 649571f), raising the minimum Multipass version to 1.14.1 for Ubuntu 24.04 buildd images. | |
| #3563 multipass: bump windows installer to 1.7.0 (CRAFT-412) | snapcraft | merged | Merged PR #3563 in c76531490, bumping Snapcraft's Windows Multipass installer to 1.7.0 and accounting for its new default of disabled privileged mounts. |