The dotnet plugin does not support the current version of .Net Core
Metadata
Current evaluation
Dotnet plugin reworked to support newer .NET Core versions and bases. Resolved by PR #3005 and #2358.
Resolution: closed resolved
Reason: The issue was closed as completed because the dotnet plugin was significantly reworked to support newer .NET Core versions (e.g., 3.1) and bases (e.g., core18). This was addressed in PR #3005 and PR #2358.
Evaluated by: mr-cal-bot
No scores available.
Issue body
I am trying to build a .Net application snap, but I am not having much luck. The application was written for .Net Core 3.0.1 (note that .Net 3.1 is also available.) When I try to build the snap using the snapcraft dotnet plugin I get the following error:
"The plugin used by part ... does not support snaps using base 'core18'."
Googling around it seems that the issue may be that the current dotnet plugin only works with Ubuntu core16 and .Net Core 2.0. These versions are outdated. Please update the dotnet plugin to support later releases of Ubuntu and .Net Core. Thanks!
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| qwen/qwen3.6-35b-a3b | — | closed resolved | Dotnet plugin reworked to support newer .NET Core versions and bases. Resolved by PR #3005 and #2358. | |
| stealth/space-bunny-alpha |
Impact:
50
Quick Win:
29
Complexity:
30
Confidence:
98
Actionability:
82
|
close resolved | The dotnet plugin’s core18 and newer .NET Core support gap was addressed by PR #3005, which added core18 compatibility and configurable runtime versions. | |
| stealth/space-bunny-alpha |
Impact:
45
Quick Win:
26
Complexity:
40
Confidence:
98
Actionability:
98
|
close resolved | Snapcraft's dotnet plugin gained core18 support and configurable .NET runtime versions in PR #3005; modern .NET builds are now documented. | |
| qwen/qwen3.6-35b-a3b |
Impact:
10
Quick Win:
9
Complexity:
10
Confidence:
100
Actionability:
100
|
close resolved | The dotnet plugin has been updated to support core18 and later bases, as well as modern .NET versions (including .NET Core 3.x and .NET 6+). The issue is resolved. | |
| qwen/qwen3.8-27b |
Impact:
10
Quick Win:
6
Staleness:
95
Complexity:
40
Confidence:
82
Support Request:
20
|
close stale | Request to update the snapcraft dotnet plugin to support .NET Core 3.0+ and bases beyond core16. The plugin has since been fully reworked in snapcraft 8.x to support core22+ and modern .NET SDKs, making this obsolete. | |
| qwen/qwen3.6-35b-a3b |
Staleness:
98
Complexity:
40
Confidence:
95
Support Request:
65
|
close stale | Request to update snapcraft's dotnet plugin to support newer Ubuntu bases and .NET Core versions. Unaddressed for over 6 years with no maintainer interaction. | |
| qwen/qwen3.6-35b-a3b |
Staleness:
98
Complexity:
30
Confidence:
95
Support Request:
15
|
close stale | Request to update snapcraft dotnet plugin for .NET Core 3.0 and Ubuntu core18. No maintainer response or comments in over six years. | |
| qwen3.6-35b-a3b-mtp-q6 |
Staleness:
98
Complexity:
35
Confidence:
92
Support Request:
10
|
close stale | Request to update snapcraft's dotnet plugin to support .Net Core 3.0 and Ubuntu core18 base. Issue is over 6 years old with no maintainer response. |
Update history
| Date | Change |
|---|---|
| created |
Related work
-
Likely Fixed By:
canonical/snapcraft#3005
(confidence 95%)
Added configurable dotnet-version support, enabled .NET Core 3.1 runtimes, and updated core18 dependencies.
-
Likely Fixed By:
canonical/snapcraft#2358
(confidence 90%)
Added support for bases in the dotnet plugin.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #1838757 dotnet plugin doesn't support .Net Core 2.1 | snapcraft (launchpad) | closed | Closed as stale after 60 days; dotnet-runtime-version 2.1.9 was confirmed working, while canonical/snapcraft#3005 added configurable runtime support. |