build(deps): enable newer pygit2 on Ubuntu 26.04
Metadata
Current evaluation
Merged in 75ec25c7, enabling pygit2 >=1.17,<1.20 for Python 3.14 on Ubuntu 26.04 while retaining the Python 3.12 constraint.
Resolution: closed resolved
Reason: PR #2676 was merged as commit 75ec25c7. It added a Python 3.14-specific pygit2 constraint for Ubuntu 26.04 and updated dependency resolution.
Evaluated by: mr-cal-bot
No scores available.
Issue body
Describe your changes.
---
- [ ] I've followed the [contribution guidelines](https://github.com/canonical/charmcraft/blob/main/CONTRIBUTING.md).
- [ ] I've signed the [CLA](http://www.ubuntu.com/legal/contributors/).
- [ ] I've successfully run `make lint && make test`.
- [ ] I've added or updated any relevant documentation.
- [ ] In documents I changed, I [added a meta description](https://canonical-starflow.readthedocs-hosted.com/how-to/add-a-page-meta-description/) if one was missing.
- [ ] I've updated the relevant release notes.
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Merged in 75ec25c7, enabling pygit2 >=1.17,<1.20 for Python 3.14 on Ubuntu 26.04 while retaining the Python 3.12 constraint. | |
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #2676 in commit 75ec25c7, enabling newer pygit2 support on Ubuntu 26.04. | |
| qwen/qwen3.6-35b-a3b | — | — | Merged to enable newer pygit2 on Ubuntu 26.04. Approved by two reviewers. CI included failing snap tests and type checking warnings, but notifications were non-blocking. Changes modified four files (+108/-13). | |
| qwen3.6-35b-a3b-mtp-q6 | — | — | Merged to enable newer pygit2 on Ubuntu 26.04. The change was accepted despite repeated non-blocking ty type checker warnings. |
Update history
No update history recorded yet.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #935 build(deps): loosen pygit2 dependency | craft-application | merged | Merged PR #935 loosened the pygit2 version constraint after verifying compatibility with intermediate and current releases, resolving #593; merged as commit 6fc53af4. | |
| #336 build(deps): use a newer pygit2 on Python 3.14 | imagecraft | merged | Merged PR #336 in commit 8f9833b, selecting newer pygit2 for Python 3.14 and refreshing uv.lock so Resolute no longer needs an older pygit2 build. | |
| #243 build(deps): make pygit2 a required dependency | craft-application | merged | Merged PR #243 made pygit2 a required runtime dependency in commit b0a3afed. | |
| #5263 build(deps): update dependency pygit2 to ~=1.17.0 (main) | snapcraft | closed | Closed unmerged after Renovate could not update uv.lock for Python 3.13 dependency resolution; the bot then ignored the pygit2 1.17.0 update. | |
| #1834 build(deps): update dependency pygit2 to v1.15.1 (main) | charmcraft | closed | Renovate PR #1834 was closed unmerged without reviews or CI; the bot ignored pygit2 1.15.1 pending a newer release. | |
| #534 build(deps): update dependency pygit2 to >=1.16.0,<1.17.0 (hotfix/4.6) - autoclosed | craft-application | closed | Renovate PR #534 proposed pygit2 1.16 for hotfix/4.6 but was autoclosed unmerged after prolonged inactivity, with no reviews or CI runs. | |
| #210 build: broaden pygit2 dependency to include 1.14 | craft-application | merged | Merged PR #210 in commit 71db9c5e broadened the pygit2 dependency to include 1.14, updated 1.14+ compatibility tests, and stopped Renovate update proposals. | |
| #593 build(deps): Figure out whether craft-application supports pygit2 version 1.16 | craft-application | closed | pygit2 1.16 compatibility was validated and the supported dependency range broadened in merged PR #935 (commit 6fc53af4), closing #593. |