build(deps): loosen pygit2 dependency
Metadata
Current evaluation
Merged PR #935 loosened the pygit2 version constraint after verifying compatibility with intermediate and current releases, resolving #593; merged as commit 6fc53af4.
Resolution: closed resolved
Reason: PR #935 was merged into main as commit 6fc53af4. It broadens supported pygit2 versions for the core26 transition and explicitly fixes issue #593.
Evaluated by: mr-cal-bot
No scores available.
Issue body
I've checked that craft-application works with each intermediate version of pygit2 up to and including the latest.
This is done for two reasons:
1. Will be needed for the core26 switch (25.10 uses pygit2 1.17 and libgit2 1.9)
2. Fixes pyright complaints about untyped parts of pygit2 1.14
Fixes #593
- [x] Have you followed the guidelines for contributing?
- [x] Have you signed the [CLA](http://www.ubuntu.com/legal/contributors/)?
- [x] Have you successfully run `make lint && make test`?
- [x] Have you added an entry to the changelog (`docs/reference/changelog.rst`)?
---
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #935 loosened the pygit2 version constraint after verifying compatibility with intermediate and current releases, resolving #593; merged as commit 6fc53af4. | |
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #935 as commit 6fc53af4, broadening support across pygit2 versions through the latest and fixing #593. | |
| stealth/space-bunny-alpha | — | closed resolved | PR #935 merged as 6fc53af4, broadening craft-application's pygit2 support through the latest release and resolving #593. | |
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #935 (commit 6fc53af4) broadened craft-application’s supported pygit2 versions through the latest release, fixing #593 and preparing for core26. | |
| qwen/qwen3.6-35b-a3b | — | — | Merged after passing CI and receiving three approvals. Loosens pygit2 dependency to support versions up to 1.17, enabling Ubuntu core26 compatibility and resolving pyright type complaints. |
Update history
No update history recorded yet.
Related work
-
Related To:
canonical/craft-application#593
(confidence 100%)
PR #935 explicitly fixes this issue by loosening the pygit2 dependency constraint.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #243 build(deps): make pygit2 a required dependency | craft-application | merged | Merged PR #243 made pygit2 a required runtime dependency in commit b0a3afed. | |
| #2676 build(deps): enable newer pygit2 on Ubuntu 26.04 | charmcraft | merged | Merged in 75ec25c7, enabling pygit2 >=1.17,<1.20 for Python 3.14 on Ubuntu 26.04 while retaining the Python 3.12 constraint. | |
| #1834 build(deps): update dependency pygit2 to v1.15.1 (main) | charmcraft | closed | Renovate PR #1834 was closed unmerged without reviews or CI; the bot ignored pygit2 1.15.1 pending a newer release. | |
| #5897 build(deps): update dependencies | snapcraft | merged | Merged PR #5897 updated Python and schema dependencies and separately bumped pygit2/libgit2 in commits 7de04a6a1 and 83ba9d714. | |
| #534 build(deps): update dependency pygit2 to >=1.16.0,<1.17.0 (hotfix/4.6) - autoclosed | craft-application | closed | Renovate PR #534 proposed pygit2 1.16 for hotfix/4.6 but was autoclosed unmerged after prolonged inactivity, with no reviews or CI runs. | |
| #336 build(deps): use a newer pygit2 on Python 3.14 | imagecraft | merged | Merged PR #336 in commit 8f9833b, selecting newer pygit2 for Python 3.14 and refreshing uv.lock so Resolute no longer needs an older pygit2 build. | |
| #5263 build(deps): update dependency pygit2 to ~=1.17.0 (main) | snapcraft | closed | Closed unmerged after Renovate could not update uv.lock for Python 3.13 dependency resolution; the bot then ignored the pygit2 1.17.0 update. | |
| #210 build: broaden pygit2 dependency to include 1.14 | craft-application | merged | Merged PR #210 in commit 71db9c5e broadened the pygit2 dependency to include 1.14, updated 1.14+ compatibility tests, and stopped Renovate update proposals. | |
| #4379 Build pygit2 as a part | snapcraft | closed | Cross-architecture builds were fixed by merged PR #4393 (commit 5fbaab144), adding a libgit2 part so pygit2 links against a compatible native library. | |
| #593 build(deps): Figure out whether craft-application supports pygit2 version 1.16 | craft-application | closed | pygit2 1.16 compatibility was validated and the supported dependency range broadened in merged PR #935 (commit 6fc53af4), closing #593. |