build: broaden pygit2 dependency to include 1.14
Metadata
Current evaluation
Merged PR #210 in commit 71db9c5e broadened the pygit2 dependency to include 1.14, updated 1.14+ compatibility tests, and stopped Renovate update proposals.
Resolution: closed resolved
Reason: PR #210 was approved and merged as commit 71db9c5e, adding pygit2 1.14 compatibility and correcting tests that require version 1.14 or newer.
Evaluated by: mr-cal-bot
No scores available.
Issue body
Drive-by: stop renovate from trying to update pygit2
- [x] Have you followed the guidelines for contributing?
- [x] Have you signed the [CLA](http://www.ubuntu.com/legal/contributors/)?
- [x] Have you successfully run `tox`?
-----
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #210 in commit 71db9c5e broadened the pygit2 dependency to include 1.14, updated 1.14+ compatibility tests, and stopped Renovate update proposals. | |
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #210 broadened craft-application's pygit2 dependency to include 1.14, stopped Renovate from proposing updates, and fixed tests for pygit2 1.14+. | |
| qwen/qwen3.6-35b-a3b | — | — | Merged after broadening the pygit2 dependency to include version 1.14. Prevents Renovate from attempting further updates and resolves a test compatibility issue for 1.14+. Approved by two reviewers with passing CI checks. |
Update history
No update history recorded yet.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #1834 build(deps): update dependency pygit2 to v1.15.1 (main) | charmcraft | closed | Renovate PR #1834 was closed unmerged without reviews or CI; the bot ignored pygit2 1.15.1 pending a newer release. | |
| #198 chore(deps): update dependency remote/pygit2 to ~=1.14.1 - autoclosed | craft-application | closed | The pygit2 1.14.1 Renovate PR was autoclosed unmerged. PR #210 (71db9c5e) superseded it by broadening the dependency to include 1.14 and disabling further updates. | |
| #5263 build(deps): update dependency pygit2 to ~=1.17.0 (main) | snapcraft | closed | Closed unmerged after Renovate could not update uv.lock for Python 3.13 dependency resolution; the bot then ignored the pygit2 1.17.0 update. | |
| #935 build(deps): loosen pygit2 dependency | craft-application | merged | Merged PR #935 loosened the pygit2 version constraint after verifying compatibility with intermediate and current releases, resolving #593; merged as commit 6fc53af4. | |
| #2676 build(deps): enable newer pygit2 on Ubuntu 26.04 | charmcraft | merged | Merged in 75ec25c7, enabling pygit2 >=1.17,<1.20 for Python 3.14 on Ubuntu 26.04 while retaining the Python 3.12 constraint. | |
| #534 build(deps): update dependency pygit2 to >=1.16.0,<1.17.0 (hotfix/4.6) - autoclosed | craft-application | closed | Renovate PR #534 proposed pygit2 1.16 for hotfix/4.6 but was autoclosed unmerged after prolonged inactivity, with no reviews or CI runs. | |
| #336 build(deps): use a newer pygit2 on Python 3.14 | imagecraft | merged | Merged PR #336 in commit 8f9833b, selecting newer pygit2 for Python 3.14 and refreshing uv.lock so Resolute no longer needs an older pygit2 build. |