build!: bump minimum Python version
Metadata
Current evaluation
Merged PR canonical/craft-application#207 (commit bf8fede0), a breaking change dropping Python 3.8 and raising the minimum to 3.9 ahead of the 2.0 release. Later commit 54b8fab4 raised the minimum further to 3.10.
Resolution: closed resolved
Reason: The PR itself was merged after approval by 3 reviewers, landing as commit bf8fede0 "build!: bump minimum Python version (#207)", which updated pyproject.toml classifiers, tox/CI matrices and lint configs across 19 files to remove Python 3.8. The minimum was subsequently raised again to 3.10 in commit 54b8fab4.
Evaluated by: mr-cal-bot
Issue body
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Merged PR canonical/craft-application#207 (commit bf8fede0), a breaking change dropping Python 3.8 and raising the minimum to 3.9 ahead of the 2.0 release. Later commit 54b8fab4 raised the minimum further to 3.10. | |
| stealth/space-bunny-alpha | — | closed resolved | Merged canonical/craft-application#207, raising the minimum Python version to 3.9 and dropping 3.8 support ahead of the 2.0 release. | |
| qwen/qwen3.6-35b-a3b | — | — | Merged after three approvals and passing CI. The change bumps the minimum supported Python version to 3.9, dropping Python 3.8 support ahead of the 2.0 release. |
Update history
No update history recorded yet.
Related work
-
Related To:
craft-application#0
(confidence 80%)
Follow-up commit 54b8fab4 "build: update minimum Python version to 3.10" superseded this minimum by raising it to 3.10; no issue number available.
-
Related To:
canonical/craft-cli#318
(confidence 70%)
Sibling craft-cli issue "drop support for old python versions", resolved in craft-cli PR #320 (commit c35189b), part of the same ecosystem-wide 3.8/3.9 drop.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #611 build!: update minimum python version to 3.10 | craft-providers | merged | Merged in #611 via commit 7c49c19, raising craft-providers' minimum supported Python version to 3.10; related integration-test failures were fixed in #606. | |
| #320 chore!: bump minimum python version to 3.10 | craft-cli | merged | Merged in canonical/craft-cli#320 via commit c35189b, raising the minimum supported Python version from earlier releases to 3.10 across 15 files. | |
| #186 bump minimal python version to 3.10 | craft-store | merged | Merged PR #186 in commit ceb4a53, raising craft-store's minimum supported Python version to 3.10 and resolving #177. |