bump minimal python version to 3.10
Metadata
Current evaluation
Merged PR #186 in commit ceb4a53, raising craft-store's minimum supported Python version to 3.10 and resolving #177.
Resolution: closed resolved
Reason: PR #186 was merged as commit ceb4a53 and explicitly states that it fixes #177. Project metadata now requires Python >=3.10.
Evaluated by: mr-cal-bot
No scores available.
Issue body
- [x] Have you followed the guidelines for contributing?
- [x] Have you signed the [CLA](http://www.ubuntu.com/legal/contributors/)?
- [x] Have you successfully run `tox`?
-----
Fixes: #177
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #186 in commit ceb4a53, raising craft-store's minimum supported Python version to 3.10 and resolving #177. | |
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #186 (commit ceb4a53) raised craft-store’s minimum supported Python version to 3.10, resolving #177. | |
| qwen/qwen3.6-35b-a3b | — | — | Merged. Bumps minimum Python version to 3.10, resolving issue #177. Approved by two reviewers, the change updates 26 files with 155 additions and 171 deletions. |
Update history
No update history recorded yet.
Related work
-
Related To:
craft-store#177
(confidence 100%)
PR #186 explicitly states that it fixes this minimum-version issue.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #729 Bump minimum Python version to 3.10 | craft-parts | closed | Minimum Python support was raised to 3.10 in commit 54b8fab4; merged PR #742 completed the broader compatibility cleanup. | |
| #207 build!: bump minimum Python version | craft-application | merged | Merged PR canonical/craft-application#207 (commit bf8fede0), a breaking change dropping Python 3.8 and raising the minimum to 3.9 ahead of the 2.0 release. Later commit 54b8fab4 raised the minimum further to 3.10. | |
| #611 build!: update minimum python version to 3.10 | craft-providers | merged | Merged in #611 via commit 7c49c19, raising craft-providers' minimum supported Python version to 3.10; related integration-test failures were fixed in #606. | |
| #177 Bump minimum python version to 3.10 | craft-store | closed | Python 3.10 became the minimum in PR #186 (commit ceb4a53); packaging metadata and uv.lock now require Python >=3.10. | |
| #320 chore!: bump minimum python version to 3.10 | craft-cli | merged | Merged in canonical/craft-cli#320 via commit c35189b, raising the minimum supported Python version from earlier releases to 3.10 across 15 files. | |
| #574 requirements: update craft-store and others | charmcraft | merged | Merged PR #574 via 0ec2094a (commit dcfdbc23), updating craft-store and other Python requirements. | |
| #49 ci: enable Python 3.10 (CRAFT-744) | craft-store | merged | Merged canonical/craft-store#49 via merge commit be09424, enabling Python 3.10 in CI; the change landed as 6a76346 and is noted in the 2.1.0 changelog. |