build(deps): update dependency sphinx-autobuild to v2025 (main)
Metadata
Current evaluation
Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11 but craft-archives requires-python is >=3.10, so uv lock failed and Renovate ignored future 2025.x releases. pyproject.toml still has sphinx-autobuild>=2024.10.3.
Resolution: closed not a bug
Reason: Renovate's artifact update aborted with 'No solution found ... sphinx-autobuild==2025.8.25 depends on Python>=3.11' against the 3.10 split, and the PR was closed without merging 2025-10-01, leaving the pin at >=2024.10.3 (no commit touches it). The bump is inapplicable while the project still declares requires-python ">=3.10" and tests3.10, so there is nothing to fix in the repo itself.
Evaluated by: mr-cal-bot
Issue body
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | β | closed not a bug | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11 but craft-archives requires-python is >=3.10, so uv lock failed and Renovate ignored future 2025.x releases. pyproject.toml still has sphinx-autobuild>=2024.10.3. | |
| stealth/space-bunny-alpha | β | closed stale | Closed unmerged: sphinx-autobuild 2025.8.25 needs Python >=3.11 but craft-archives requires-python is >=3.10, so uv.lock could not be regenerated. Renovate ignored future 2025.x updates. | |
| stealth/space-bunny-alpha | β | closed not a bug | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python 3.11+, so uv could not regenerate uv.lock for the projectβs Python 3.10 support. Renovate will ignore future 2025.x updates. | |
| qwen/qwen3.6-35b-a3b | β | β | Closed without merging due to a Python version conflict. The sphinx-autobuild update requires Python 3.11+, but the project uses 3.10, causing uv.lock resolution to fail. Renovate will ignore future 2025.x updates. |
Update history
No update history recorded yet.
Related work
-
Related To:
canonical/starbase#436
(confidence 80%)
Identical sphinx-autobuild 2025.8.25 Renovate PR closed unmerged for the same Python 3.10 uv.lock resolution failure.
-
Related To:
canonical/debcraft#16
(confidence 75%)
Same update closed unmerged after uv lock failed on the Python 3.10 split; repeat attempt #30 also closed.
-
Related To:
canonical/craft-providers#815
(confidence 70%)
Sibling Canonical repo PR closed because sphinx-autobuild v2025 needs Python >= 3.11.
-
Related To:
canonical/craft-platforms#188
(confidence 65%)
Same dependency update closed unmerged due to a uv.lock resolution failure for Python 3.10.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #30 build(deps): update dependency sphinx-autobuild to v2025 (main) | debcraft | closed | Renovate's sphinx-autobuild ~=2024.2 -> ~=2025.8 bump was closed unmerged on 2025-10-25 after uv lock failed (2025.8.25 needs Python >=3.11; debcraft supports >=3.10). pyproject.toml still pins sphinx-autobuild>=2024.10.3. | |
| #120 build(deps): update dependency sphinx-autobuild to v2025 | craft-grammar | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python 3.11+, while craft-grammar supports Python 3.10, so Renovate could not update uv.lock. | |
| #436 build(deps): update dependency sphinx-autobuild to v2025 | starbase | closed | Closed unmerged: sphinx-autobuild 2025.8.25 required Python >=3.11, so uv could not resolve the Python 3.10 lock split; Renovate ignored future 2025.x updates. | |
| #456 build(deps): update dependency sphinx-autobuild to v2025 (main) | starbase | closed | Closed unmerged after uv could not resolve sphinx-autobuild 2025.8.25 on supported Python 3.10; Renovate is now ignoring future 2025.x updates. | |
| #46 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-artifacts | closed | Renovate PR #46 (sphinx-autobuild 2024.2 -> 2025.8) was closed unmerged: the lockfile update failed because 2025.8.25 needs Python >=3.11 while the project still supports 3.10. pyproject.toml still pins ~=2024.2. | |
| #149 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-grammar | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, but craft-grammar supports Python 3.10, so uv could not resolve uv.lock. | |
| #165 build(deps): update dependency sphinx-autobuild to v2025 | craft-platforms | closed | Closed unmerged after Renovate could not update uv.lock for sphinx-autobuild 2025.8.25 on Python 3.10; no fixing commit landed. | |
| #188 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-platforms | closed | Renovate's sphinx-autobuild 2025 update was closed unmerged after uv could not resolve uv.lock for Python 3.10; no update landed. | |
| #895 build(deps): update dependency sphinx-autobuild to v2025 (hotfix/5.9) | craft-application | closed | Closed unmerged after uv could not resolve sphinx-autobuild 2025.8.25 for Python 3.10; Renovate then ignored future 2025.x updates. | |
| #883 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-application | closed | Renovate PR #883 was closed unmerged after uv could not resolve sphinx-autobuild 2025.8.25 for Python 3.10; 2025.8.25 later entered uv.lock via #1085 (2a6a7320). |