build(deps): update dependency sphinx-autobuild to v2025
Metadata
Current evaluation
Closed unmerged: sphinx-autobuild 2025.8.25 requires Python 3.11+, while craft-grammar supports Python 3.10, so Renovate could not update uv.lock.
Resolution: closed not a bug
Reason: Renovate's 2025-08-31 comment documented the failed lockfile resolution because sphinx-autobuild 2025.8.25 requires Python >=3.11 while the project resolves Python 3.10. PR #120 was subsequently closed without merging.
Evaluated by: mr-cal-bot
No scores available.
Issue body
This PR contains the following updates:
| Package | Change | Age | Confidence |
|---|---|---|---|
| [sphinx-autobuild](https://redirect.github.com/sphinx-doc/sphinx-autobuild#readme) ([changelog](https://redirect.github.com/sphinx-doc/sphinx-autobuild/blob/main/NEWS.rst)) | `~=2024.2` -> `~=2025.8` | [](https://docs.renovatebot.com/merge-confidence/) | [](https://docs.renovatebot.com/merge-confidence/) |
---
### Release Notes
<details>
<summary>sphinx-doc/sphinx-autobuild (sphinx-autobuild)</summary>
### [`v2025.8.25`](https://redirect.github.com/sphinx-doc/sphinx-autobuild/compare/2024.10.03...2025.08.25)
[Compare Source](https://redirect.github.com/sphinx-doc/sphinx-autobuild/compare/2024.10.03...2025.08.25)
</details>
---
### Configuration
📅 **Schedule**: Branch creation - "every weekend" in timezone Etc/UTC, Automerge - At any time (no schedule defined).
🚦 **Automerge**: Disabled by config. Please merge this manually once you are satisfied.
♻ **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.
🔕 **Ignore**: Close this PR and you won't be reminded about this update again.
---
- [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box
---
This PR was generated by [Mend Renovate](https://mend.io/renovate/). View the [repository job log](https://developer.mend.io/github/canonical/craft-grammar).
<!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiI0MS45MS4xIiwidXBkYXRlZEluVmVyIjoiNDEuOTEuMSIsInRhcmdldEJyYW5jaCI6Im1haW4iLCJsYWJlbHMiOlsiUFI6IERlcGVuZGVuY2llcyJdfQ==-->
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed not a bug | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python 3.11+, while craft-grammar supports Python 3.10, so Renovate could not update uv.lock. | |
| stealth/space-bunny-alpha | — | closed stale | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, but uv.lock includes Python 3.10, so Renovate failed to update the lockfile and ignored future 2025.x updates. | |
| stealth/space-bunny-alpha | — | closed stale | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python 3.11+, but uv could not update the Python 3.10-compatible lockfile. Renovate disabled future 2025.x updates. | |
| stealth/space-bunny-alpha | — | closed stale | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, but craft-grammar supports Python 3.10, so uv.lock could not be regenerated. Renovate ignored future 2025.x updates. | |
| qwen/qwen3.6-35b-a3b | — | — | Closed without merging. Renovate failed to update uv.lock due to a Python version conflict, as sphinx-autobuild v2025.8.25 requires Python 3.11+ but the project uses 3.10. Renovate will ignore future 2025.x updates for this dependency. |
Update history
No update history recorded yet.
Related work
-
Related To:
canonical/craft-grammar#187
(confidence 85%)
Later PR #187 updated docs/sphinx-autobuild to a 2024 release compatible with the retained Python 3.10 support.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #149 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-grammar | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, but craft-grammar supports Python 3.10, so uv could not resolve uv.lock. | |
| #206 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-archives | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11 but craft-archives requires-python is >=3.10, so uv lock failed and Renovate ignored future 2025.x releases. pyproject.toml still has sphinx-autobuild>=2024.10.3. | |
| #165 build(deps): update dependency sphinx-autobuild to v2025 | craft-platforms | closed | Closed unmerged after Renovate could not update uv.lock for sphinx-autobuild 2025.8.25 on Python 3.10; no fixing commit landed. | |
| #436 build(deps): update dependency sphinx-autobuild to v2025 | starbase | closed | Closed unmerged: sphinx-autobuild 2025.8.25 required Python >=3.11, so uv could not resolve the Python 3.10 lock split; Renovate ignored future 2025.x updates. | |
| #456 build(deps): update dependency sphinx-autobuild to v2025 (main) | starbase | closed | Closed unmerged after uv could not resolve sphinx-autobuild 2025.8.25 on supported Python 3.10; Renovate is now ignoring future 2025.x updates. | |
| #188 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-platforms | closed | Renovate's sphinx-autobuild 2025 update was closed unmerged after uv could not resolve uv.lock for Python 3.10; no update landed. | |
| #32 build(deps): update dependency sphinx-autobuild to v2025 | craft-artifacts | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python 3.11, so uv.lock could not resolve the Python 3.10 environment; the same update was later retried in #46. | |
| #815 build(deps): update dependency sphinx-autobuild to v2025 (main) | craft-providers | closed | Closed unmerged: sphinx-autobuild 2025.8.25 requires Python >=3.11, so the lockfile update failed in craft-providers' supported Python 3.10 environment. | |
| #16 build(deps): update dependency sphinx-autobuild to v2025 | debcraft | closed | Closed unmerged after uv lock failed because sphinx-autobuild 2025.8.25 requires Python 3.11 while debcraft supports 3.10. A later identical update, PR #30, was also closed unmerged. | |
| #938 build(deps): update dependency sphinx-autobuild to v2025 (hotfix/5.10) | craft-application | closed | PR #938 was closed unmerged after uv could not resolve sphinx-autobuild 2025.8.25 for Python 3.10/Questing; no 2025 update landed, and Renovate stopped proposing 2025.x updates. |