← Back to issue list

Bump minimum version of Multipass to 1.14.1

View original Github issue

Metadata

Project
craft-providers
Number
#638
Type
issue
State
closed
Author
mr-cal
Labels
—
Created
Updated
Closed

Current evaluation

Fixed by merged PR #694 (commit 649571f), raising the minimum Multipass version to 1.14.1 for Ubuntu 24.04 buildd images.

Resolution: closed resolved

Reason: PR #694 was merged as commit 649571f. The requirement was raised to Multipass>=1.14.1 and released in craft-providers 2.0.1 and 1.24.2.

Evaluated by: mr-cal-bot

No scores available.

Issue body

### What needs to get done Once Multipass 1.14.1 is released to `latest/stable`, craft-providers should bump the [minimum required version](https://github.com/canonical/craft-providers/blob/88dfb55229d6e274754f58df4d21ec9b5a3696b7/craft_providers/multipass/multipass.py#L51) to 1.14.1. ### Why it needs to get done Multipass 1.14.1 is required for launching 24.04 buildd images.

Evaluation history

Date Model Scores Action Summary
stealth/space-bunny-alpha — closed resolved Fixed by merged PR #694 (commit 649571f), raising the minimum Multipass version to 1.14.1 for Ubuntu 24.04 buildd images.
qwen/qwen3.6-35b-a3b — closed resolved Bumped minimum Multipass version to 1.14.1 in merged PR #694 to support launching Ubuntu 24.04 buildd images.

Update history

Date Change
created

Related work

Related issues

Issue Project State Summary Similarity
#694 chore: require multipass>=1.14.1 craft-providers merged Merged PR #694 (commit 649571f) raised the minimum supported Multipass version to 1.14.1, fixing #638 and enabling Ubuntu 24.04 buildd image launches.
76%
#640 fix: require multipass>=1.14.1 for Ubuntu 24.04 (Noble) craft-providers merged Merged PR #640 (commit a977369) requiring Multipass >=1.14.1 for Ubuntu 24.04 Noble VMs, fixing #628 after the snapcraft:devel alias moved to 24.10 images.
75%
#602 fix(multipass): use Ubuntu 24.04 image craft-providers merged Merged PR #602 updated Multipass Noble to the Ubuntu 24.04 buildd daily image, fixing #511. Resolved by commit a369826.
74%
#628 Check Multipass version for 24.04 VMs craft-providers closed Implemented a Multipass >=1.14.1 requirement for Noble/24.04 launches in commit a977369 and released it in craft-providers 1.24.2 and 2.0.1.
71%
#1796303 Check version of multipass snapcraft (launchpad) closed Added a Multipass minimum-version check via canonical/craft-providers#42, requiring Multipass 1.7+; merged as ce6356d.
71%