fix: require multipass>=1.14.1 for Ubuntu 24.04 (Noble)
Metadata
Current evaluation
Merged PR #640 (commit a977369) requiring Multipass >=1.14.1 for Ubuntu 24.04 Noble VMs, fixing #628 after the snapcraft:devel alias moved to 24.10 images.
Resolution: closed resolved
Reason: PR #640 was merged as commit a977369 and added the Multipass >=1.14.1 requirement for launching Noble VMs, addressing #628/CRAFT-3270. PR #694 later made 1.14.1 the general minimum in commit 649571f.
Evaluated by: mr-cal-bot
No scores available.
Issue body
- [x] Have you followed the guidelines for contributing?
- [x] Have you signed the [CLA](http://www.ubuntu.com/legal/contributors/)?
- [x] Have you successfully run `tox`?
-----
Require Multipass>=`1.14.1` for launching Ubuntu 24.04 (Noble).
Previously, Multipass had been using the `snapcraft:devel` alias for 24.04 images (#602). This worked until last month when the `devel` alias started pointing to `24.10` images.
Once Multipass `1.14.1` is released to `latest/stable` and to homebrew, this can be reverted and the minimum Multipass version will be bumped to `1.14.1` (#638).
Fixes #628
(CRAFT-3270)
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #640 (commit a977369) requiring Multipass >=1.14.1 for Ubuntu 24.04 Noble VMs, fixing #628 after the snapcraft:devel alias moved to 24.10 images. | |
| qwen/qwen3.6-35b-a3b | — | closed resolved | Fixed in merged PR by requiring multipass>=1.14.1 for Ubuntu 24.04 (Noble), resolving the snapcraft:devel alias pointing to 24.10 images. |
Update history
| Date | Change |
|---|---|
| created |
Related work
-
Related To:
canonical/craft-providers#628
(confidence 100%)
PR #640 explicitly identifies #628 as fixed.
-
Related To:
canonical/craft-providers#638
(confidence 100%)
Follow-up issue for making Multipass 1.14.1 the general minimum.
-
Related To:
canonical/craft-providers#694
(confidence 100%)
Later follow-up PR merged as commit 649571f to require Multipass >=1.14.1 generally.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #602 fix(multipass): use Ubuntu 24.04 image | craft-providers | merged | Merged PR #602 updated Multipass Noble to the Ubuntu 24.04 buildd daily image, fixing #511. Resolved by commit a369826. | |
| #628 Check Multipass version for 24.04 VMs | craft-providers | closed | Implemented a Multipass >=1.14.1 requirement for Noble/24.04 launches in commit a977369 and released it in craft-providers 1.24.2 and 2.0.1. | |
| #638 Bump minimum version of Multipass to 1.14.1 | craft-providers | closed | Fixed by merged PR #694 (commit 649571f), raising the minimum Multipass version to 1.14.1 for Ubuntu 24.04 buildd images. | |
| #694 chore: require multipass>=1.14.1 | craft-providers | merged | Merged PR #694 (commit 649571f) raised the minimum supported Multipass version to 1.14.1, fixing #638 and enabling Ubuntu 24.04 buildd image launches. | |
| #511 Re-point multipass noble image when 24.04 is released | craft-providers | closed | Fixed by merged PR #602 (commit a369826), which repointed Multipass Noble to the Ubuntu 24.04 buildd image instead of the development image. |