Bump minimum Python version to 3.10
Metadata
Current evaluation
Minimum Python support was raised to 3.10 in commit 54b8fab4; merged PR #742 completed the broader compatibility cleanup.
Resolution: closed resolved
Reason: Commit 54b8fab4 raised the package minimum to Python 3.10. Merged PR #742 (a80f9c26) subsequently completed the broader Python 3.10 compatibility changes.
Evaluated by: mr-cal-bot
No scores available.
Issue body
### What needs to get done
Bump minimum Python version to 3.10
### Why it needs to get done
Because.
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Minimum Python support was raised to 3.10 in commit 54b8fab4; merged PR #742 completed the broader compatibility cleanup. | |
| stealth/space-bunny-alpha | — | closed resolved | Minimum Python version was raised to 3.10 in commit 54b8fab4 ("build: update minimum Python version to 3.10"). | |
| qwen/qwen3.6-35b-a3b | — | — | Abandoned and closed without implementation. The request to bump the minimum Python version to 3.10 received no discussion or changes, with only an automated Jira sync comment logged. | |
| qwen/qwen3.6-35b-a3b | — | — | Closed without resolution. The request to bump the minimum Python version to 3.10 was abandoned with no pull requests or code changes implemented. | |
| qwen/qwen3.6-35b-a3b | — | — | Requesting a minimum Python version bump to 3.10 was closed and abandoned. No technical discussion or resolution occurred beyond an automated Jira sync, leaving the change unimplemented. | |
| qwen3.6-35b-a3b-mtp-q6 | — | — | Closed without resolution. The request to bump the minimum Python version to 3.10 was synced to Jira but no implementation, merge, or follow-up actions were recorded. |
Update history
No update history recorded yet.
Related work
-
Likely Fixed By:
canonical/craft-parts#742
(confidence 98%)
Merged PR raising requires-python to >=3.10 and completing compatibility cleanup.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #177 Bump minimum python version to 3.10 | craft-store | closed | Python 3.10 became the minimum in PR #186 (commit ceb4a53); packaging metadata and uv.lock now require Python >=3.10. | |
| #116 Drop Python < 3.10 | craft-archives | closed | Python 3.9 and older support was removed by merged PR #117, raising the minimum supported version to Python 3.10 (commit ccfdcbf). | |
| #186 bump minimal python version to 3.10 | craft-store | merged | Merged PR #186 in commit ceb4a53, raising craft-store's minimum supported Python version to 3.10 and resolving #177. | |
| #117 chore!: bump minimum Python version to 3.10 | craft-archives | merged | Merged PR #117 as commit ccfdcbf, raising the minimum supported Python version from 3.9 to 3.10 and resolving #116. | |
| #178 chore!: bump minimum Python version to 3.10 | craft-store | closed | Closed unmerged; the Python 3.10 minimum-version bump subsequently landed via PR #186 in commit ceb4a53. | |
| #318 drop support for old python versions | craft-cli | closed | Minimum Python raised to 3.10 in merged PR #320 (commit c35189b, 'chore!: bump minimum python version to 3.10'), dropping 3.8/3.9; pyproject.toml now has requires-python >=3.10. | |
| #5546 build: reduce minimum Python version to 3.10 | snapcraft | closed | Closed unmerged as superseded by #5547, which merged as f0532a15d, reducing the minimum Python version from 3.12 to 3.10 and fixing #5522. |