Drop minimum Python version to 3.10
Metadata
Current evaluation
Minimum Python in pyproject.toml lowered from 3.12 to 3.10 by merged PR #5547 (commit f0532a15d), unblocking the core22-8 rock; maintainer mr-cal closed the issue citing that PR.
Resolution: closed resolved
Reason: PR #5547 ("build: reduce minimum Python version to 3.10") was merged as commit f0532a15d and its description explicitly states it fixes #5522. Current pyproject.toml in snapcraft shows requires-python = ">=3.10", confirming the change landed.
Evaluated by: mr-cal-bot
No scores available.
Issue body
### What needs to get done
Drop the minimum Python version in `pyproject.toml` from Python 3.12 to Python 3.10.
### Why it needs to get done
To enable the core22-8 rock of Snapcraft without needing to provision a custom version of Python.
Evaluation history
| Date | Model | Scores | Action | Summary |
|---|---|---|---|---|
| stealth/space-bunny-alpha | — | closed resolved | Minimum Python in pyproject.toml lowered from 3.12 to 3.10 by merged PR #5547 (commit f0532a15d), unblocking the core22-8 rock; maintainer mr-cal closed the issue citing that PR. | |
| stealth/space-bunny-alpha | — | closed resolved | Merged PR #5547 as commit f0532a15d, lowering the minimum Python version from 3.12 to 3.10 and unblocking core22-8. | |
| stealth/space-bunny-alpha | — | closed resolved | Python 3.10 support was restored by merged PR #5547 (commit f0532a15d), reducing the minimum from 3.12 to 3.10. | |
| qwen/qwen3.6-35b-a3b | — | — | Dropped minimum Python version from 3.12 to 3.10 in pyproject.toml. Resolved and merged via pull request #5547, enabling the core22-8 Snapcraft rock without custom Python provisioning. | |
| qwen/qwen3.6-35b-a3b | — | — | The minimum Python version was lowered from 3.12 to 3.10 to enable the core22-8 snap without a custom Python installation. The change was fixed and merged via pull request 5547. | |
| qwen3.6-35b-a3b-mtp-q6 | — | — | Minimum Python version in pyproject.toml was dropped from 3.12 to 3.10 to enable core22-8 without custom Python provisioning. The change was fixed and merged via pull request #5547. |
Update history
No update history recorded yet.
Related work
-
Likely Fixed By:
canonical/snapcraft#5547
(confidence 99%)
Merged PR reducing requires-python from >=3.12 to >=3.10; closing comment by mr-cal links it as the fix.
Related issues
| Issue | Project | State | Summary | Similarity |
|---|---|---|---|---|
| #318 drop support for old python versions | craft-cli | closed | Minimum Python raised to 3.10 in merged PR #320 (commit c35189b, 'chore!: bump minimum python version to 3.10'), dropping 3.8/3.9; pyproject.toml now has requires-python >=3.10. | |
| #116 Drop Python < 3.10 | craft-archives | closed | Python 3.9 and older support was removed by merged PR #117, raising the minimum supported version to Python 3.10 (commit ccfdcbf). |