← Back to issue list

Drop Python < 3.10

View original Github issue

Metadata

Project
craft-archives
Number
#116
Type
issue
State
closed
Author
lengau
Labels
—
Created
Updated
Closed

Current evaluation

Python 3.9 and older support was removed by merged PR #117, raising the minimum supported version to Python 3.10 (commit ccfdcbf).

Resolution: closed resolved

Reason: PR #117 was merged and commit ccfdcbf updated the project metadata to require Python 3.10 or newer. The maintainer explicitly marked the work completed in #117.

Evaluated by: mr-cal-bot

No scores available.

Issue body

### What needs to get done Drop support for python versions below 3.10 ### Why it needs to get done Helps modernise the code.

Evaluation history

Date Model Scores Action Summary
stealth/space-bunny-alpha — closed resolved Python 3.9 and older support was removed by merged PR #117, raising the minimum supported version to Python 3.10 (commit ccfdcbf).
stealth/space-bunny-alpha — closed resolved Dropped support for Python < 3.10 via merged craft-archives PR #117, raising the minimum supported version to 3.10; CI passed.
qwen/qwen3.6-35b-a3b — — Dropped support for Python versions below 3.10 to modernize the codebase. Completed and merged via pull request #117.
qwen/qwen3.6-35b-a3b — — Dropped support for Python versions below 3.10 to modernize the codebase. Resolved by merging pull request #117.
qwen/qwen3.6-35b-a3b — — Dropped support for Python versions below 3.10 to modernize the codebase. The change was completed and merged via pull request #117.

Update history

No update history recorded yet.

Related work

Related issues

Issue Project State Summary Similarity
#729 Bump minimum Python version to 3.10 craft-parts closed Minimum Python support was raised to 3.10 in commit 54b8fab4; merged PR #742 completed the broader compatibility cleanup.
77%
#318 drop support for old python versions craft-cli closed Minimum Python raised to 3.10 in merged PR #320 (commit c35189b, 'chore!: bump minimum python version to 3.10'), dropping 3.8/3.9; pyproject.toml now has requires-python >=3.10.
77%
#5522 Drop minimum Python version to 3.10 snapcraft closed Minimum Python in pyproject.toml lowered from 3.12 to 3.10 by merged PR #5547 (commit f0532a15d), unblocking the core22-8 rock; maintainer mr-cal closed the issue citing that PR.
71%